
American Innovations (AI) is pleased to announce version 1.9 of our Pipeline Compliance System Axis® 
software (PCS Axis®). This document explains how to install PCS Axis in a client/server network (Figure 1). 

Figure 1.  PCS Axis Client/Server Installation

Information in this document is intended for your company’s IT System Administrator, Database 
Administrator (DBA), and PCS Axis Administrator. 

IMPORTANT: The person who installs and sets up the PCS Axis database on the central database server 
must have full DBA privileges and be a member of the sysadmin fixed server role. 

Topics in this document include those in the following list:

 PCS Axis Best Practices (page 2)

 Installation Overview (page 9)

 Installation Requirements (page 11)

 Adding the Local Domain User Group Axis_Users (page 14)

 Restoring the PCS Axis Database and Setting Permission Roles (page 15)

 Running Fill Factor Reset and Creating a Database Maintenance Job (page 17)

 Installing PCS Axis Job Service (page 18)

 Starting PCS Axis Job Service (page 21)

 Installing the PCS Axis Application on a Local Client Computer (page 24)

 Setting Up Users in PCS Axis (page 29)

 Installation Checklist (page 30)

 Product Support and Training (page 31)
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PCS Axis Best Practices is a series of topics demonstrating best practices for setting up the PCS Axis® 
database and related services on a network server running Microsoft® SQL Server® 2008 R2. Topics 
include those in the following list:

 Importing Large Amounts of Data in PCS Axis

 Running PCS Axis Job Service

 Managing the PCS Axis Database (page 4)

 Running SQL Server (MSSQLServer) Service (page 7)

Importing Large Amounts of Data in PCS Axis

Index fragmentation may occur in the PCS Axis database after importing large amounts of data using 
Bridge Import, Bullhorn Bridge, or Field Computer. Index fragmentation can result in slow system 
performance. The list below identifies best practice methods that can prevent index fragmentation: 

 Enable the option Reindex after import in the Bridge definition of a Bridge Import or Bullhorn 
Bridge. See PCS Axis Help for more information. 

 Create a scheduled database maintenance job on the central database server using the Reindex 
Stored Procedure provided with the PCS Axis installation file. See the next section for information 
about how to create a scheduled database maintenance job. 

Running PCS Axis Job Service

Run the PCS Axis Job Service under a domain account or a SQL Server account with access to the server 
and PCS Axis database. To set up PCS Axis Job Service, follow these steps: 

1 Click the Windows Start button  and navigate to Computer. Right-click Computer and select 
Manage in the shortcut menu to open the Computer Management console (Figure 2, page 3). 

2 Double-click Services and Applications in the left pane of the console. Then click Services to 
display a list of services in the middle pane. 

PCS Axis Best Practices
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Figure 2.  Computer Management Console

3 Right-click PCS Axis Job Service 1.9 and select Properties in the shortcut menu to open the 
Properties dialog box (Figure 3, page 4). 

4 Click the Log On tab and select the option This account. 

5 Set up PCS Axis Job Service with a user account to log on as a service using a domain account or 
a SQL Server account with access to the server and PCS Axis database. Type the user name and 
password in the appropriate fields (This account, Password, Confirm Password). You can also 
view a list of appropriate user account by clicking Browse > Advanced > Find Now. 

NOTE: The user account must be a member of the Axis_Users group and have access to the 
database server and PCS Axis database. 

6 Click Apply and then OK to close the Properties dialog box and return to the Computer 
Management console. 

7 Click File > Exit to close the Computer Management console. 
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Figure 3.  PCS Axis Job Service 1.9 Properties

Managing the PCS Axis Database

Information in this section covers best practices for managing the PCS Axis database using Microsoft® SQL 
Server® Management Studio (SSMS). Topics include those in the following list:

 Setting the Database Owner

 Recommended Autogrowth Setting (page 5)

Setting the Database Owner

To prevent errors from occurring when migrating or restoring the PCS Axis database, or when establishing 
a connection, set the “Owner” of the database using the “sa” account. To set the database “Owner” follow 
these steps: 

1 Start SQL Server Management Studio (SSMS). Click Start > Microsoft SQL Server 2008 R2 > SQL 
Server Management Studio. 

2 Double-click the Databases folder in Object Explorer to open the folder. 

3 Right-click the PCS Axis database and select Properties in the shortcut menu to open the 
Database Properties dialog box (Figure 4, page 5). 

4 Select Files in the Select a page navigation panel. 

5 Type sa in the Owner field. Then click OK to save changes and close the dialog box. 
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Figure 4.  Database Owner

Recommended Autogrowth Setting

Information in this section applies to the PCS Axis database and log file. If you are running PCS Axis in a 
client/server network with synchronization, the information also applies to the publication and subscription 
databases. 

Autogrowth indicates how much additional space is allocated when the PCS Axis database and log file 
require more space. Setting Autogrowth properties allow the PCS Axis database and log file to resize 
automatically based on a predetermined percentage. Because the database resizing process is a significant 
drain on computer resources, it is recommended that you set properties in a manner that does not allow 
the database to constantly resize itself. 

NOTE: When using PCS Axis with synchronization, set Autogrowth properties after you create the 
publication and subscription databases. 

To set Autogrowth properties for the database (_dat) and log (_log) files, follow these steps:

1 Start SSMS. Click Start > Microsoft SQL Server 2008 R2 > SQL Server Management Studio.

2 Double-click Databases in Object Explorer. 

3 Right-click the PCS Axis database and select Properties in the shortcut menu to open the Database 
Properties dialog box.

4 Click Files in the Select a page navigation panel (Figure 5, page 6). 
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Figure 5.  Files - Database Properties

5 Complete the following steps to set Autogrowth properties for the database (_dat) and log (_log) 
files: 

a Click the … ellipsis button in the Autogrowth column of the database _dat file to open the 
Change Autogrowth dialog box (Figure 6). 

b Click the Enable Autogrowth check box to place a check mark inside the check box. 

c For the File Growth property setting, select the option In Percent and then type 10 in the 
adjacent field. This property setting automatically allocates 10% additional space when the 
database requires more space. 

d Click OK to close the Change Autogrowth dialog box.

e Repeat step 5 for the database _log file. 

f Click OK to close the Database Properties dialog box. Then click File > Exit to exit SSMS. 

Figure 6.  Change Autogrowth
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Running SQL Server (MSSQLServer) Service

Run the Windows SQL Server (MSSQLSERVER) service under a domain account with access to the PCS 
Axis database. To set up the service, follow these steps: 

1 Click the Windows Start button  and navigate to Computer. Right-click Computer and select 
Manage in the shortcut menu to open the Computer Management console (Figure 7). 

2 Double-click Services and Applications in the left pane of the console. Then click Services to 
display a list of services in the middle pane. 

Figure 7.  Computer Management Console

3 Right-click SQL Server (MSSQLSERVER) and select Properties in the shortcut menu to open the 
Properties dialog box (Figure 8). 

Figure 8.  SQL Server (MSSQLSERVER) Properties
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4 Click the Log On tab and select the option This account. 

5 Set up SQL Server (MSSQLSERVER) with a user account to log on as a service using a domain 
account with access to the PCS Axis database. Type the user name and password in the appropriate 
fields (This account, Password, Confirm Password). You can also view a list of appropriate user 
account by clicking Browse > Advanced > Find Now. 

6 Click Apply and then OK to close the Properties dialog box and return to the Computer 
Management console. 

7 Click File > Exit to close the Computer Management console. 
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Installation tasks covered in this document include those identified in the following list. The term central 
database server is used in this document to refer to a network server or host computer. 

IT System Administrator Tasks

 Run Windows Computer Management on the central database server to create a local 
domain user group named Axis_Users. Add all PCS Axis users in the Axis_Users group with 
appropriate permissions to access the central database server. See Adding the Local Domain 
User Group Axis_Users (page 14). 

NOTE: Remaining IT System Administrator tasks are completed when Database Administrator 
tasks are completed. 

 Install the PCS Axis Job Service on the same server as the PCS Axis database or on a separate 
network server. See Installing PCS Axis Job Service (page 18). 

 Start PCS Axis Job Service (see page 21). 

 Install the PCS Axis application on the local computer of the PCS Axis Administrator and all 
other users. Use Connection Manager during the installation to set the server and database 
connection to the PCS Axis database on the central database server. See Installing the PCS 
Axis Application on a Local Client Computer (page 24). 

Database Administrator Tasks

 Restore the PCS Axis database on the central database server using the database backup file 
provided by PCS Technical Services. See Restoring the PCS Axis Database and Setting 
Permission Roles (page 15). 

IMPORTANT: If someone other than your company’s Database Administrator (DBA) plans to 
restore the PCS Axis database and create the publication database, this person must have full 
DBA privileges and be a member of the sysadmin fixed server role to successfully complete the 
database tasks on the central database server. 

 Run the Fill Factor Reset script labeled Defrag Fill Factor Reset Post Deployment.SQL to 
reset the fill factor limit of the PCS Axis database. The Fill Factor Reset script is included in the 
PCS Axis download package provided by PCS Technical Services. Run this script after installing 
or upgrading the publication database as well as creating one or more subscription databases. 
See Running Fill Factor Reset and Creating a Database Maintenance Job (page 17). 

Installation Overview
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Database Administrator Tasks, continued

 Create a scheduled database maintenance job on the central database server using the Reindex 
Stored Procedure labeled dbo.DefragmentIndexes. The stored procedure is included in the 
PCS Axis download package provided by PCS Technical Services. See Running Fill Factor Reset 
and Creating a Database Maintenance Job (page 17). 

NOTE: SQL server maintenance jobs can only be created when running a full version of SQL 
server. SQL Server Express does not support this feature. 

 Create a new login for the PCS Axis database labeled Axis_Users. Set permission roles for the 
Axis_Users login to allow PCS Axis users access to the PCS Axis database. See Restoring the 
PCS Axis Database and Setting Permission Roles (page 15). 

PCS Axis Administrator Task

Run the PCS Axis application to add all PCS Axis users in User Management. See Setting Up Users in 
PCS Axis, page 29.
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Before installing PCS Axis, verify the following items are available and the client and server computers meet 
the system requirements identified in Table 1 (page 12) and Table 2 (page 13). 

 PCS Axis License File: The installation process prompts you for the PCS Axis license file provided 
by AI.

 Bridge Import License File: If your company purchased the optional Bridge add-on to import 
data from a third-party application, activating Bridge import for operation requires the license file 
provided by AI.

NOTE: A Bridge license file is not required to import data from Bullhorn® Asset Tracker (BAT™) or 
export data from PCS Axis. You can maintain all PCS Axis licenses for your organization in the same 
shared folder location. PCS Axis will request the file and location the first time each user opens the 
PCS Axis application. The Bridge activation key is assigned only once for the PCS Axis database; 
once it is assigned it functions for all users.

 PCS Axis Installation File: Install PCS Axis using either the installation DVD provided by AI or the 
installation file downloaded from a location identified in an email from PCS Technical Services. 

 System Requirements: Verify the server and client computers meet the system requirements 
identified in Table 1 (page 12) and Table 2 (page 13). 

Installation Requirements
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NOTES:

• Microsoft .NET Framework : If the target computer does not have Microsoft .NET Framework v4.5 
installed, the PCS Axis installation automatically installs it for you. This feature requires an active 
Internet connection to complete the installation of .NET Framework v4.5. 

• PCS Axis Installation: By default, only the PCS Axis application is selected for installation on the 
computer of local clients in a client/server network. See Table 2 (page 13) for information about the 
system requirements for installing the PCS Axis database and job service on the central database 
server. 

• Microsoft SQL Server Express 2008 R2 SP2, 64-bit: For client systems that wish to use 
Synchronization, a 64-bit version of Microsoft SQL Server 2008 Express R2 SP2 (or Standard edition 
for databases exceeding 10 GB) must be installed on the subscriber’s computer (the remote client). 
Once PCS Axis is installed, a subscription database must be created on the subscriber’s computer 
prior to working off-line.

• Disk Space with Synchronization: If using a remote client to subscribe to and synchronize with a 
central database, sufficient disk space must be reserved for database use (11 GB when using 
Microsoft SQL Server 2008 Express).

Table 1.  Local Client Computer Requirements

Properties Recommended

Processor Intel Core i7

Processor Speed 2.3 GHz or faster

RAM 8 GB

Operating System Windows 7 64-bit, Service Pack 1 (SP1)

Available Disk Space 720 MB

Resolution 1920x1080

Microsoft .NET Framework Version 4.5 (see note)
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NOTES:

• Larger databases may require more RAM for optimum performance. 

• Hosting the PCS database on a shared SQL server may result in poor performance.

• Consult with your company’s IT personnel or DBA to determine where database backups will be 
created. 

• The PCS Axis database installs on the central database server. If selected in Setup Wizard during the 
installation, the PCS Axis application and job service can install on the central database server as well. 
For local client and subscriber computer requirements, see Table 1 (page 12). 

Table 2.  Dedicated Central Database Server Requirements

Properties Recommended

Processor Intel Xeon

Processor Speed 2 Quad Core CPUs at 2.4 GHz or faster

RAM 32 GB (see note)

Operating System Windows Server 2008 R2

Relational Database Software SQL Server 2008 R2

Available Disk Space 100 GB (see note)

Resolution 1920x1080
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Information in this section explains how to add a local domain user group on the central database server 
labeled Axis_Users. By adding the Axis_Users group, all PCS Axis users will have access to the server. The 
following information is intended for the IT System Administrator. 

Complete the following steps on the central database server:

1 Open Computer Management. Click Start > Administrative Tools > Computer Management. 

2 Click to expand System Tools and then Local Users and Groups in the navigation tree. 

3 To add the local domain user group labeled Axis_Users, follow these steps: 

a Right-click Groups and select New Group in the shortcut menu to open the New Group dialog 
box (Figure 9). 

b Type Axis_Users in the Group name field and a description for the user group in the 
Description field. 

c Click Add > Advanced > Find Now to view a list of user names. Add all PCS Axis users in the 
Axis_Users group. 

d Click Create and then click Close to close the dialog box. 

4 After the Database Administrator has restored the PCS Axis database on the central database server 
(see page 15), continue the installation with the section titled Installing PCS Axis Job Service 
(page 18). 

Figure 9.  Axis_Users Local Domain User Group

Adding the Local Domain User Group Axis_Users
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Information in this section is intended for the Database Administrator. The information explains how to:

 Restore the backup file of the PCS Axis database on the central database server. 

 Create a new login for the PCS Axis database labeled Axis_Users. Then set permission roles for the 
new login labeled Axis_Users. 

Complete the following steps on the central database server: 

1 Using the database backup file provided by PCS Technical Services, restore the PCS Axis database. 

2 Start SQL Server Management Studio (SSMS). Connect to the central database server and then 
switch to the PCS Axis database. 

3 Click to expand Security, then Logins in the navigation tree of Object Explorer. Right-click Logins 
and select New Login in the shortcut menu to open the Login-New dialog box (Figure 10). 

Figure 10.  Login-New

4 Set the following properties in the General page: 

a Type Axis_Users in the Login name field. If the group name Axis_Users does not appear in the 
selection list, complete the following steps: 

(1) Select Find People in the selection list to open the Select Users or Groups dialog box. 

(2) Click Object Types to open the Object Types dialog box. 

Restoring the PCS Axis Database and Setting Permission Roles
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(3) Click the Group check box, then click OK to return to the File Sharing dialog box. 

(4) Select Axis_Users in the selection list, then click Add. 

b Enable the option Windows authentication if it is not enabled.

c Select the PCS Axis database in the Default database field. 

5 Click Server Roles in Select a page and enable the public check box. 

6 Click User Mapping in Select a page and enable the following properties:

a In the group box Users mapped to this login, enable the PCS Axis database. 

b In the group box Database role membership for, enable the following properties: 

 Axis_Users

 db_datareader

 db_datawriter

 db_ddladmin

 db_owner

 public

c Click OK to save settings and close the Login-New dialog box. 

Tasks performed by the Database Administrator are now complete. 
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Information in this section is intended for the Database Administrator (DBA). The information explains how 
to complete the following tasks on the central database server after installing or upgrading the PCS Axis 
database:

 Run the Fill Factor Rest script labeled Defrag Fill Factor Reset Post Deployment.SQL to reset 
the fill factor limit of the publication database. 

 Use the Reindex Stored Procedure labeled dbo.DefragmentIndexes to create a scheduled 
database maintenance job. The stored procedure is intended to optimize system performance by 
reorganizing and defragmenting the indexes in the PCS Axis database. 

IMPORTANT: Schedule the database maintenance job to run daily or once a week during an off-
peak time. Scheduling the database maintenance job at regular intervals will ensure optimum 
system performance. 

Complete the following steps: 

1 Start SQL Server Management Studio (SSMS). Click Start > All Programs > Microsoft SQL Server 
2008 R2 > SQL Server Management Studio. 

2 Use SSMS to run the Fill Factor Reset script labeled Defrag Fill Factor Reset Post Deployment.SQL 
on the PCS Axis database. 

3 Use SSMS to create a scheduled database maintenance job for the PCS Axis database using the 
Reindex Stored Procedure labeled dbo.DefragmentIndexes. Set the job to run daily or once a 
week during an off-peak time. 

IMPORTANT:  AI recommends running the stored procedure daily or once a week during non-peak 
hours. 

For a best practice guide in creating database maintenance jobs, visit the Microsoft website at
http://technet.microsoft.com/en-us/library/ms187658(v=sql.105).aspx.

4 Exit SSMS. 

Running Fill Factor Reset and Creating a Database Maintenance Job
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The following information is intended for the IT System Administrator. It explains how to install PCS Axis 
Job Service on a network server. You can install the service either on the same server as the PCS Axis 
database or on a separate network server. 

Complete the following steps:

1 If you are using the installation DVD to install PCS Axis, insert the DVD in the DVD/CD-ROM drive of 
the computer. Open Windows Explorer to view the contents of the installation DVD.

If you previously downloaded the installation file using a link in an email from PCS Technical 
Services, navigate to the location of the installation file. 

NOTE: A single installation file labeled setup.exe is used to install PCS Axis on a 32-bit and 64-bit 
computer. If the target computer does not have Microsoft .NET Framework v4.5 installed, the PCS 
Axis installation automatically installs it. This feature requires an active Internet connection to 
complete the installation of .NET Framework v4.5. 

2 Double-click the setup.exe installation file to open the PCS Axis dialog box (Figure 11). 

 

Figure 11.  PCS Axis Installation

3 Click Install in the PCS Axis dialog box to open Setup Wizard (Figure 12, page 19). 

4 Click Next to read the End-User License Agreement. To accept the license agreement, click the 
check box I accept the terms in the License Agreement to place a check mark inside the check box. 

Installing PCS Axis Job Service
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Figure 12.  Setup Wizard

5 Click Next to display Custom Setup (Figure 13). 

6 By default the PCS Axis application is selected for installation. If you are working on the central 
database server and do not want to install the application on the server, click the down arrow in 

 PCS Axis and select the option Entire feature will be unavailable. 

7 By default the PCS Axis Job Service is not selected for installation. To install the service on the 
server, click the down arrow in  PCS Axis Job Service and select the option Entire feature will 
be installed on local hard drive. 

8 Click Next and then click Install to begin the installation. 

Figure 13.  Custom Setup
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When the installation completes and after a short delay, Connection Manager opens 
automatically on top of Setup Wizard (Figure 14). 

9 Complete the following steps in Connection Manager to set Server and Database settings: 

a Type the name of the central database server in the Server field. Or click Select in the Server 
field to select the server in the Select Server dialog box.

b Type the name of the PCS Axis database in the Database field. Or click Select in the Database 
field to select the database in the Select Database dialog box.

c Click  Test to verify the connection to the server and database. When the message 
Connection successful displays, click  OK to close the message. 

d Click  Save and Close to exit Connection Manager.

10 Click Finish in Setup Wizard and then click Close in the PCS Axis dialog box to close the PCS Axis 
installation file (setup.exe). 

11 Installation of the PCS Axis Job Service is now complete. Continue with the next section to start 
the service (page 21). 

Figure 14.  Connection Manager
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The purpose of PCS Axis Job Service is to monitor the PCS Axis job queue, initiating jobs as they become 
available. The following procedure explains how to use Windows Services to start PCS Axis Job Service. 
The information is intended for the IT System Administrator. 

Complete the following steps: 

1 If the PCS Axis database and PCS Axis Job Service are installed on two different network servers, 
complete the following steps to set up a user account to log on as a service. The user account must 
have access to the central database server and PCS Axis database. 

a Click the Windows Start button  and navigate to Computer. Right-click Computer and 
select Manage in the shortcut menu to open the Computer Management console (Figure 15). 

b Double-click Services and Applications in the left pane of the console. Then click Services 
to display a list of services in the middle pane. 

Figure 15.  Computer Management Console

c Right-click PCS Axis Job Service 1.9 (Figure 15) and select Properties in the shortcut menu 
to open the Properties dialog box (Figure 16, page 22). 

d Click the Log On tab and select the option This account. To set up a user account to log on as 
a service, type the user name and password in the appropriate fields. You can view a list of 
appropriate user accounts by clicking Browse > Advanced > Find Now. 

NOTE: The user account must be a member of the Axis_Users group and have access to the 
central database server and PCS Axis database. 

Starting PCS Axis Job Service
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e Click Apply and then OK to close the Properties dialog box and return to the Computer 
Management console. 

Figure 16.  PCS Axis Job Service 1.9 Properties

2 Complete the following steps in the Computer Management console to start PCS Axis Job 
Service: 

a Select PCS Axis Job Service 1.9 and then click Start (Figure 17). 

b Click File > Exit to close the Computer Management console. 

Figure 17.  Computer Management Console
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c In PCS Axis, click Tools > Job Service Viewer. Verify the message Running displays in the 
Status field (Figure 18). 

Starting PCS Axis Job Service is now complete. Continue with the next section to install the 
PCS Axis application on local client computers (page 24). 

Figure 18.  Job Service Console
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Information in this section is intended for the IT System Administrator. It explains how to install only the 
PCS Axis application on the computer of local client users. 

Complete the following steps: 

1 If you are using the installation DVD to install PCS Axis, insert the DVD in the DVD/CD-ROM drive of 
the computer. Open Windows Explorer to view the contents of the installation DVD.

If you previously downloaded the installation file using a link in an email from PCS Technical 
Services, navigate to the location of the installation file. 

NOTE: A single installation file labeled setup.exe is used to install PCS Axis on a 32-bit and 64-bit 
computer. If the target computer does not have Microsoft .NET Framework v4.5 installed, the PCS 
Axis installation automatically installs it. This feature requires an active Internet connection to 
complete the installation of .NET Framework v4.5. 

2 Double-click the setup.exe installation file to open the PCS Axis dialog box (Figure 19). 

 

Figure 19.  PCS Axis Installation

3 Click Install in the PCS Axis dialog box to open Setup Wizard (Figure 20, page 25). 

4 Click Next to read the End-User License Agreement. To accept the license agreement, click the 
check box I accept the terms in the License Agreement to place a check mark inside the check box. 

Installing the PCS Axis Application on a Local Client Computer
PCS Axis v1.9 Client/Server New Installation (without Replication) 24 of 31
pcstechservices@aiworldwide.com

mailto:pcstechservices@aiworldwide.com


 

Figure 20.  Setup Wizard

5 Click Next to display Custom Setup (Figure 21). 

6 By default the  PCS Axis application is selected for installation. The  PCS Axis Job Service 
should not be selected for installation. Verify selections in Custom Setup match those in the 
following figure (Figure 21). 

7 Click Next and then click Install to begin the installation. 

Figure 21.  Custom Setup
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When the installation completes and after a short delay, Connection Manager opens 
automatically on top of Setup Wizard (Figure 22). 

8 Use Connection Manager to establish a connection to the PCS Axis database on the central 
database server as follows:

a Type the name of the central database server in the Server field. Or click Select in the Server 
field to select the server in the Select Server dialog box. 

b Type the name of the PCS Axis database in the Database field. Or click Select in the Database 
field to select the database in the Select Database dialog box. 

c Click  Test to verify the connection to the server and database. When the message 
Connection successful displays, click  OK to close the message. Click  Save and Close to 
exit Connection Manager. 

9 Click Finish in Setup Wizard and then click Close in the PCS Axis dialog box to close the PCS Axis 
installation file (setup.exe). 

Figure 22.  Connection Manager

10 Start PCS Axis on the client computer. Click the Windows  Start button, then All Programs > 
 PCS Axis 1.9. 

11 When the Activation Key message opens, click  OK and then locate and select your PCS Axis 
activation key (Figure 23, page 27). 

12 When the License Agreement window opens, click  I Agree. 
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Figure 23.  Activation Key

13 If your company purchased the optional Bridge import add-on, complete the following steps to 
activate the feature for operation:

a Click Tools > Job Service Viewer to open the Job Service Console (Figure 24). 

b Click Activate Bridge Import License. When the Activation Key dialog box opens, navigate to 
the license file and select it. Then click Open to close the dialog box and return to the Job 
Service Console. 

The message Valid displays in the License field. If Not Valid displays instead, contact PCS 
Technical Services for assistance using the contact information on page 31. 

Figure 24.  Job Service Console
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14 Open the About window in PCS Axis to view information about the software and database version. 
Click Help > About PCS Axis to open the About window (Figure 25). 

NOTE: Clicking Copy To Clipboard in the About window copies the following information to the 
Windows clipboard: database connection; software application version; and build information (date 
and time). After copying information to the clipboard, you can then paste it in an email or other 
type of document, such as Microsoft Word. Use this feature when contacting PCS Technical Services 
for support with PCS Axis.

Figure 25.  About PCS Axis

15 Repeat the steps in this section (pages 24-28) to install the PCS Axis application on all other local 
client computers. 

The local client installation is complete after installing the PCS Axis application on all local client 
computers. Continue with the next section to set up users in PCS Axis (page 29). 
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Information in this section explains how to add users in User Management of PCS Axis. The information is 
intended for the PCS Axis Administrator. 

Complete the following steps:

1 Start the PCS Axis application and then click Tools > User Management >  Add. 

2 Type the user's Windows domain user name in the User Name field and then press Tab. PCS Axis 
automatically adds the user's email address. Verify Active is enabled. 

3 Update other information as needed, such as a user Role selection. 

4 Click Save and then repeat step 2 for each user you want to add. If needed, click the  help button 
in User Management to view related information. 

Setting Up Users in PCS Axis
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IT System Administrator Tasks

 Create a local domain user group labeled Axis_Users on the central database server. Add PCS 
Axis users to the Axis_Users group who are listed in Windows Active Directory. 

NOTE: Remaining IT tasks are completed when Database Administrator tasks are completed.

 Install PCS Axis Job Service on the same server as the PCS Axis database or on a separate 
network server. Then use Windows Services to start PCS Axis Job Service. 

 Install the PCS Axis application on the local computer of the PCS Axis Administrator and all other 
users. Use PCS Axis Connection Manager during the installation to set the server and database 
connection. 

Database Administrator Tasks 

 Restore the PCS Axis database on the central database server. 

 Use SQL Server Management Studio (SSMS) to run the provided Fill Factor Reset script labeled 
Defrag Fill Factor Reset Post Deployment.SQL. Run this script after installing or upgrading 
the publication database as well as creating one or more subscription database(s). 

 Use SSMS to create a database maintenance job using the provided Reindex Stored Procedure 
labeled dbo.DefragmentIndexes. 

 Create a new login for the PCS Axis database labeled Axis_Users. 

 Set the following permission roles for the new login Axis_Users:

 Axis_Users

 db_datareader

 db_datawriter

 db_ddladmin

 db_owner

 public

PCS Axis Administrator Task

 Run PCS Axis and add users in User Management. 

Installation Checklist
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If you have a suggestion, question, feature request, or a bug to report-your feedback would be 
appreciated. Also if you have a training need for your organization or would like to know more about 
upcoming PCS Axis training classes, please use any of the following contact information to reach PCS 
Technical Services:

Support E-mail: pcstechservices@aiworldwide.com

Support Telephone: 1-800-229-3404 (select 1, then press 2)

American Innovations: http://www.aiworldwide.com

Product Support and Training
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